Skip to main content

Topic: Qt version (Read 176 times)

  • cantanima
  • [*]
Qt version
Hello

I tried to run the latest AppImage of Otter on Linux, in hopes that the password function would work. Alas, it gave me the following error:

Code: [Select]
$ my_applications/otter-browser-0.9.91-weekly180-x86_64.AppImage 
./otter-browser: ./lib/libQt5Core.so.5: version `Qt_5.7' not found (required by /lib64/libQt5Quick.so.5)
./otter-browser: ./lib/libQt5Core.so.5: version `Qt_5.7' not found (required by /lib64/libQt5WebChannel.so.5)

Weekly 175 worked without trouble. Will there be a future version that goes back the earlier requirement? (e.g., the webpage still lists 5.4 as the requirement) If not, should one download 5.7 from Qt and install it? (I did notice they're up to 5.9 now)
Cogitor, ergo sum. -- Franz von Baadke

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Qt version
Reply #1
@cantanima, I guess that our build machine got messed up somehow, I'm planning to setup new one anyway, so AppImage could take advantage of new features in Qt 5.9.
5.4 is still the minimal required version and AppImage is built against Qt 5.6 (LTS release).
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Qt version
Reply #2
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.