Skip to main content

Topic: Otter 0.4.01 Released (Read 4569 times)

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Otter 0.4.01 Released
Another "boring" release (hopefully next one will be finally more exciting).

0.4.01 (01.04.2014):
- added basic full screen mode support;
- User Agents configuration;
- various tab bar related fixes;
- some other fixes and changes.
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

Re: Otter 0.4.01 Released
Reply #1
New round. :pirate:
Fortuna fortes juvat.

  • ersi
  • [*][*][*][*][*]
Re: Otter 0.4.01 Released
Reply #2
The previous release (alpha 3) was instantly available in Arch/Manjaro repos. Not so with this one, so I can't update it the easy way. I will report back if/when/how I manage to do it.

Edit: yaourt -Sa otter-browser
Must remember that.
  • Last Edit: 2014-04-02, 07:25:05 by ersi

  • ersi
  • [*][*][*][*][*]
Re: Otter 0.4.01 Released
Reply #3
There was almost a day delay to Manjaro repos (the thing called Pacman). Now it's there. Updating on the other machine too right now.

Re: Otter 0.4.01 Released
Reply #4
I did a short test of 0.4.01 today and I wonder if this would be a proper place for commenting about shortcomings.
Maybe there is already a list with known issues and my comments would be redundant.
However since I'm on it two things I've noticed:
- Using a local proxy, search doesn't work - "Error 103, No suitable proxy found"
- There is no option to set the max (persistent) connections per proxy. As a result the default value is used (6?) and therefore some pages are loading very slow.

BTW, "about:config" is really poor. Since Otter is only in an early alpha stage, I hope it's a work in progress. :cheers:

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Otter 0.4.01 Released
Reply #5
Using a local proxy, search doesn't work - "Error 103, No suitable proxy found"

More details please. :-)

There is no option to set the max (persistent) connections per proxy. As a result the default value is used (6?) and therefore some pages are loading very slow.

It's not available, you can try to request it upstream (QtNetwork module):
http://qt-project.org/wiki/ReportingBugsInQt

BTW, "about:config" is really poor. Since Otter is only in an early alpha stage, I hope it's a work in progress.

You mean amount of options? Surely there will be more in future. ;-)
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

Re: Otter 0.4.01 Released
Reply #6

More details please. :-)

Proxy settings:
HTTP = 127.0.0.1:8080
HTTPS = 127.0.0.1:8080
Try to make a search with one of the search engines shipped with Otter and you'll get the error message above.
I'm using Proxomitron as local proxy but you can check with any other local proxy you wish.


It's not available, you can try to request it upstream (QtNetwork module):
http://qt-project.org/wiki/ReportingBugsInQt

Hmm, without this option any use of a local proxy is basically futile.
Browsers don't make distinction between a local proxy server and a common one so max connections for a server will be applied to the local proxy server (which basically is a gateway) too.
That's one of the reasons why any decent browser should have this network option. Can't tell for every browser but Opera >12 and Firefox (and its derivates) have it.

Edit:
Speaking of the network modul:
How about pipelining - is it enabled by default? Is it enabled for proxy servers too?
How about SPDY - is it enabled by default? If so how can I disable it?
How about Websocket - is it enabled by default? If so how can I disable it?

Just a few things that came to my mind right now, I'm sure that there are more.
  • Last Edit: 2014-04-09, 23:13:33 by krake

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Otter 0.4.01 Released
Reply #7
@krake, thanks, I'll try to reproduce that later.
Hmm, without this option any use of a local proxy is basically futile.

Well, it has to be done upstream...
How about pipelining - is it enabled by default? Is it enabled for proxy servers too?

It's not, but can be enabled separately for each request using QNetworkRequest::HttpPipeliningAllowedAttribute:
Quote
Requests only, type: QMetaType::Bool (default: false) Indicates whether the QNetworkAccessManager code is allowed to use HTTP pipelining with this request.

How about SPDY - is it enabled by default? If so how can I disable it?

SPDY will be available with Qt 5.3 and AFAIK there is no option to disable it.
How about Websocket - is it enabled by default? If so how can I disable it?

Always enabled.
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

Re: Otter 0.4.01 Released
Reply #8
I'm trying to install it without installing the Qt SDK.

I'm in Kubuntu 14.04, and I see some package that I imagine would be useful :
There is no libqt5 but there are :
- libqt5core5a
- libqt5network5
- libqt5printsupport5
- libqt5script5
- libqt5sql5
- libqt5widgets5
- libqt5webkit5

Every one of them in 5.2.1.

And there isn't libqt5webkitwidgets5.

Is there a way to depend only on those package instead of libqt5 (and maybe libqt5webkitwidgets5) ?

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Otter 0.4.01 Released
Reply #9
Cqoicebordel, are you using some PPA for current Qt5?
I see only again outdated Qt5 packages in official repository, 5.1.1. :-|
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

Re: Otter 0.4.01 Released
Reply #10
I don't think so. I checked and Muon tells me that libqt5core5a's Origin is Ubuntu.
And above all, https://launchpad.net/ubuntu/trusty/i386/libqt5core5a lists it as 5.2.1. You also have some package here : https://launchpad.net/ubuntu/+source/qtbase-opensource-src

Are you sure to be in 14.04 ? And if so, did you reactivate the sources and apt-get update ?

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Otter 0.4.01 Released
Reply #11
Cqoicebordel, right, I've checked only libqt5webkit and it seems that it's stuck at 5.1.1.
Maybe that package also contains widgets... I haven't tried system packages yet, maybe I'll try that tomorrow.
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.