Skip to main content

Topic: Weekly79 Qtweb engine? (Read 2768 times)

  • jasonliul
  • [*][*]
Weekly79 Qtweb engine?
Wow, blink.
:cheers:
Fortuna fortes juvat.

  • kanakomoerer
  • [*]
Re: Weekly79 Qtweb engine?
Reply #1
i found a bug.
all ad-blockings are no control.
:worried:

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Weekly79 Qtweb engine?
Reply #2
@kanakomoerer, that backend is called experimental for a reason. ;-)
It will become more usable with Qt 5.6, then content blocking and some more stuff should be finally possible.
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

  • kanakomoerer
  • [*]
Re: Weekly79 Qtweb engine?
Reply #3
okay emdek, i understood you.Now version79 (x86), this command-log appear.

- - - -
Warning: QObject::connect: Cannot connect (null)::subWindowactivated(QmdiSubWindow*) to Otter::WorkspaceWidget::activeSubWindowCanged(qMdiSubWindow*) ((null):0, (null))

- - - -
Now version79 (x64) cannot start.
  • Last Edit: 2015-07-08, 09:26:34 by kanakomoerer

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Weekly79 Qtweb engine?
Reply #4
@kanakomoerer, are you using 64 bit package or 32 bit one, standard or with QtWebEngine?
That warning is harmless and was fixed in master.
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

  • kanakomoerer
  • [*]
Re: Weekly79 Qtweb engine?
Reply #5
Now version79 (x64) standard can start.
Now version79 (x86) standard can start.
Now version79 (x86) qtwebengine can start with only qt5.5 installed machine.Html5test result is 515 (!!).

Now version79 (x64) qtwebengine-version cannot start.
log is here.
- - - -
[0709/095632:ERROR:icu_util.cc(154)] Couldn't mmap C:\Users\myfolder\Downloads\otter-browser-win64-weekly79-qtwebengine\icudtl.dat
[0709/095632:FATAL:content_main_runner.cc(747)] Check failed: base::i18n::InitializeICU().
- - - -
  • Last Edit: 2015-07-09, 01:17:10 by kanakomoerer

  • exley
  • [*][*][*]
Re: Weekly79 Qtweb engine?
Reply #6
so you gonna use Blink or do we wait for gecko version ?
you wrote that Blink is unstable

  • kanakomoerer
  • [*]
Re: Weekly79 Qtweb engine?
Reply #7
I don't hurry up development of this browser qtwebengine-version. Please develop your pace. :)
  • Last Edit: 2015-07-09, 05:36:24 by kanakomoerer

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Weekly79 Qtweb engine?
Reply #8
@kanakomoerer, it appears that we need to ship some extra files that were not mentioned in documentation, plus installer (at least for 32 bit) is totally broken due to missing exe for web process...
Next one should be in better shape. ;-)

@exley, don't worry, we can have multiple backends on single installation (as long they won't complain, QtWebKit works fine when QtWebEngine is available, in fact you can have one tab using first backend and another with the latter).
QtWebEngine is quite stable but doesn't expose all needed APIs yet (for more advanced stuff, like managing cookies, cache etc.) and is missing some features (for example no Pepper flash yet).
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

  • exley
  • [*][*][*]
Re: Weekly79 Qtweb engine?
Reply #9
well I asked coz you said QTWebKit is dead, QTblink has unstable API
so now I'm confused what to use :P

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Weekly79 Qtweb engine?
Reply #10
@exley, that depends on your needs, QtWebEngine should be in usable state before next beta, but for more advanced features like managing cookies, content blocking etc. we will need to wait to at least Qt 5.6.
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

  • exley
  • [*][*][*]
Re: Weekly79 Qtweb engine?
Reply #11
ok now you confused me totally

so is QTWebEngine WebKit, Blink, or something 3rd ?, their site only says porting of chromium to QT

whilst you said in another thread like already written above, that QTWebKit is DEAD
and QTBlink unstable
and now after all this, what the hell is QTwebengine at the end ?

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Weekly79 Qtweb engine?
Reply #12
@exley, QtWebEngine means Qt APIs for Chromium which is Blink plus some extra stuff.
Blink was forked from WebKit but it became very different (in terms of API etc.).
QtWebKit is almost dead, it will be worse when 4.6 will arrive...
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Weekly79 Qtweb engine?
Reply #13
I'm uploading v2 packages for QtWebEngine flavor 32 bit, please check if they work correctly now.
All missing files should be now included, terminal should no longer show up and Windows XP support should be back.
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

  • kanakomoerer
  • [*]
Re: Weekly79 Qtweb engine?
Reply #14
now weekly79v2 can start without qt5.5, but scroll bar is red and cannot input password or (any words) correctly into form. i use copy-and-paste for password. ???

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Weekly79 Qtweb engine?
Reply #15
@kanakomoerer, are you using high DPI?
I've seen reports about red scrollbar when running in such mode, AFAIK default resources don't include high resolution images or something like that.
Hopefully it will be fixed in 5.5.1 (although probably there is no ETA for that).
I guess that it's time to create test-qtwebengine, that would help with debugging that inputs issue.
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.