Skip to main content

Topic: Fonts (Read 1536 times)

  • Belfrager
  • [*][*][*][*][*]
Fonts
Comparing the same webpage rendered by Otter (0.9.09 beta 9) and Opera (12.16) , one can notice that using the same font (DejaVu Serif) at both browser's settings as the normal font, the text at Otter appears more "bolded" than at Opera.

Do I have any way to correct this?
Thks




A matter of attitude.

  • Frenzie
  • [*][*][*][*][*]
  • Administrator
Re: Fonts
Reply #1
It's possible that you might need to do something geeky like create a ~/.config/fontconfig/fonts.conf file to match up your GTK and Qt styles. Mine contains the following:

Code: [Select]
<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
<match target="font" >
<edit mode="assign" name="hinting">
<bool>true</bool>
</edit>
</match>
<match target="font" >
<edit mode="assign" name="hintstyle">
<const>hintfull</const>
</edit>
</match>
<match target="font" >
<edit mode="assign" name="antialias">
<bool>true</bool>
</edit>
</match>
<match target="font" >
<edit mode="assign" name="rgba">
<const>rgb</const>
</edit>
</match>
<match target="font">
<edit mode="assign" name="lcdfilter">
<const>lcdlegacy</const>
</edit>
</match>
</fontconfig>


Anyway, between the lines I mean that looking bolder is probably a stronger hinting or antialiasing. I'm sorry I don't have any direct solution to offer. Btw, which version of Ubuntu is this?

  • Belfrager
  • [*][*][*][*][*]
Re: Fonts
Reply #2
Thanks frenzie but creating config files it's beyond my knowledge as a simple user.
It's strange because I would swear that we're looking into two different fonts.

Using Ubuntu MATE 15.10.
A matter of attitude.

  • Frenzie
  • [*][*][*][*][*]
  • Administrator
Re: Fonts
Reply #3
Have you tried going into the font configuration to see if that changes anything? There's a blog post about it here: http://feeblemind.tuxfamily.org/blog/index.php?post/2013/02/02/Linux-Mint%2C-MATE-and-fonts

  • Belfrager
  • [*][*][*][*][*]
Re: Fonts
Reply #4

Have you tried going into the font configuration to see if that changes anything? There's a blog post about it here: http://feeblemind.tuxfamily.org/blog/index.php?post/2013/02/02/Linux-Mint%2C-MATE-and-fonts


I did but as I thought it does not make any difference. OS settings should act globally not affecting just one browser.
(The picture above is from the desktop with Otter and Opera simultaneously rendering the same page, both running under the same OS settings, therefore I think any differences must be the result of each browser settings.)

The mystery is that both browsers are using DejaVu Serif font as the normal font but the result is very different, even looking as two completely different fonts not just effects applied over the font. (you may want to open the image in other tab, at full size, to realize it clearly.)

Maybe the two browsers simply renders the same font in different ways... I don't know...  :eyes:
A matter of attitude.

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Fonts
Reply #5
@Belfrager, this might be some issue in QtWebKit or QtGui.
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

  • ovas
  • [*][*]
Re: Fonts
Reply #6
Not display the font on websites changed the encoding does not work, before such was not.

  • TheSpecialOne
  • [*]
Re: Fonts
Reply #7
Same here. I get also fancy/disturbed/bold appearance compared to Opera. But only with some fonts... and testet on windows, so I also guess this has something to do with the rendering engine and some sort of antialising/cleartype.

Any suggestions?

  • Zero3K
  • [*]
Re: Fonts
Reply #8
I also notice a similar issue involving fonts displayed on CNN.com, etc. I hope that it's a fixable issue and is fixed in a later build.