Skip to main content

Topic: Problem of popup window on Ubuntu 14.04 (otter version - 0.9.11) (Read 254 times)

  • mad_king
  • [*]
Problem of popup window on Ubuntu 14.04 (otter version - 0.9.11)
I am trying to allow popup settings for browser but showing following error

"New tabs or windows are being blocked by your browser!  Please allow popups for this site".

In setting allowed the popup already.

Checked also with latest version of otter but same problem.  Is anything more required for this functionality?.

Checked with Windows and works fine


  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Problem of popup window on Ubuntu 14.04 (otter version - 0.9.11)
Reply #1
@mad_king, 0.9.11 is outdated and shouldn't be used anymore, also it uses incompatible configuration option names.
In case of recent weeklies make sure that Permissions/ScriptsCanOpenWindows is set to openAll in about:config.
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

  • mad_king
  • [*]
Re: Problem of popup window on Ubuntu 14.04 (otter version - 0.9.11)
Reply #2
No luck

Permission/ScriptCanOpenWindows has been set to openAll

otter.conf
[Permissions]
ScriptsCanOpenWindows=openAll

In diagnostic report we can see
Permissions/ScriptCanOpenWindows      ask      default    no overrides

For Windows
Permissions/ScriptCanOpenWindows      ask     non default    1 override (s)

Might be something missing with setting for Linux platform?

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Problem of popup window on Ubuntu 14.04 (otter version - 0.9.11)
Reply #3
@mad_king, maybe I should try to reproduce it, is that some public URL?
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

  • mad_king
  • [*]
Re: Problem of popup window on Ubuntu 14.04 (otter version - 0.9.11)
Reply #4
url has sent to your personal message

  • mad_king
  • [*]
Re: Problem of popup window on Ubuntu 14.04 (otter version - 0.9.11)
Reply #5
@Emdek
Could you able to reproduce it?

Thanks

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Problem of popup window on Ubuntu 14.04 (otter version - 0.9.11)
Reply #6
@mad_king, works for me, once you trigger popup you should see toolbar on the top of the page where you can decide what to do using Details button, you can use first option to allow opening them.
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

  • mad_king
  • [*]
Re: Problem of popup window on Ubuntu 14.04 (otter version - 0.9.11)
Reply #7
@Emdek

Work for Windows as well as Linux for you? Which Linux flavor Ubuntu? version?
Still i could not figure out how to do this.

Thanks

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Problem of popup window on Ubuntu 14.04 (otter version - 0.9.11)
Reply #8
@mad_king, works fine under Windows 10.
You can also enable popups for that page without trigerring popup, just open Website Preferences (for example using F12 menu) and then change setting for Pop-ups in the first tab and Apply changes.
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

  • mad_king
  • [*]
Re: Problem of popup window on Ubuntu 14.04 (otter version - 0.9.11)
Reply #9
@Emdek

Yes its works perfect for Windows 10 but not for Ubuntu (VM on Windows 10).
Also did exactly as you mentioned above post for Ubuntu but no luck. I am getting message "New tabs or windows are being blocked by your browser!  Please allow popups for this site"

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Problem of popup window on Ubuntu 14.04 (otter version - 0.9.11)
Reply #10
@mad_king, uhm, what sort of package are you using there, which version of browser and QtWebKit?
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

  • mad_king
  • [*]
Re: Problem of popup window on Ubuntu 14.04 (otter version - 0.9.11)
Reply #11
@Emdek
Ubuntu 14.04 LTS
otter - 0.9.91-dev175
Qt version - Qt 5.8.0 (with qtwebengine)

Thanks

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Problem of popup window on Ubuntu 14.04 (otter version - 0.9.11)
Reply #12
@mad_king, QtWebEngine might explain this, try AppImage for weekly 189 (newest one won't work there), and if it won't work then you are left with PPA packages.

But if you are using SDK then update to Qt 5.9.x and grab binaries here:
https://github.com/annulen/webkit/releases/tag/qtwebkit-5.212.0-alpha2
Just unpack it into matching folders in prefix used by 5.9 from SDK and rerun CMake.
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.