Skip to main content

Topic: SSL support is not available or incomplete. 0.9.91-rc1v2-x86_64.AppImage (Read 207 times)

SSL support is not available or incomplete. 0.9.91-rc1v2-x86_64.AppImage
I receive the following with 0.9.91-rc1v2-x86_64.AppImage.:

SSL support is not available or incomplete.
Some website may work incorrectly or do not work at all.

I've compiled OpenSSL-1.1.0f and did not receive the error when I last tested an app image.

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: SSL support is not available or incomplete. 0.9.91-rc1v2-x86_64.AppImage
Reply #1
@rhubarbpieguy, that AppImage still can use OpenSSL 1.0 only, probably next one will contain extra variant of QtNetwork that is supposed to be compatible with 1.1.
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

Re: SSL support is not available or incomplete. 0.9.91-rc1v2-x86_64.AppImage
Reply #2
@rhubarbpieguy, that AppImage still can use OpenSSL 1.0 only, probably next one will contain extra variant of QtNetwork that is supposed to be compatible with 1.1.

The 0.9.92-rc2-x86_64.AppImage still bombs with OpenSSL 1.0 using Linux.  I realize the response stated "probably."  Just reporting.

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: SSL support is not available or incomplete. 0.9.91-rc1v2-x86_64.AppImage
Reply #3
@rhubarbpieguy, well, nothing changed so far regarding support for OpenSSL 1.1, it turns out that usually both are available anyway (but 1.0 might require manual installation).
Check if 1.0 is available for your system, if yes then try installing it, and let me know if that worked.
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

Re: SSL support is not available or incomplete. 0.9.91-rc1v2-x86_64.AppImage
Reply #4
Check if 1.0 is available for your system, if yes then try installing it, and let me know if that worked.

I compiled openssl-1.0 and still receive:

  SSL support is not available or incomplete. 
  Some website may work incorrectly or do not work at all.

The find command reports only openssl-1.0 so I assume I'm using 1.0.

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: SSL support is not available or incomplete. 0.9.91-rc1v2-x86_64.AppImage
Reply #5
@rhubarbpieguy, uhm, perhaps it ended in some directory where Qt is not looking for it, I think that these are the paths used to locate it:
http://code.qt.io/cgit/qt/qtbase.git/tree/src/network/ssl/qsslsocket_openssl_symbols.cpp?h=5.10#n626
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

Re: SSL support is not available or incomplete. 0.9.91-rc1v2-x86_64.AppImage
Reply #6
uhm, perhaps it ended in some directory where Qt is not looking for it, I think that these are the paths used to locate it:

After viewing your link it seems openssl should be found.  Executing 'find' shows the following:

/etc/ssl/openssl.cnf
/etc/ssl/openssl.cnf.dist
/usr/bin/openssl
/usr/include/openssl
/usr/include/openssl/opensslconf.h
/usr/include/openssl/opensslv.h
/usr/include/openssl-1.0
/usr/include/openssl-1.0/openssl
/usr/include/openssl-1.0/openssl/opensslconf.h
/usr/include/openssl-1.0/openssl/opensslv.h
/usr/lib/libevent_openssl-2.1.so.6
/usr/lib/libevent_openssl-2.1.so.6.0.2
/usr/lib/libevent_openssl.la
/usr/lib/libevent_openssl.so
/usr/lib/openssl-1.0
/usr/lib/openssl-1.0/pkgconfig/openssl.pc
/usr/lib/pkgconfig/libevent_openssl.pc
/usr/lib/pkgconfig/openssl.pc

As I mentioned, I don't remember this problem with previous AppImages.  But with that said, I can't exclude a problem on my end.

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: SSL support is not available or incomplete. 0.9.91-rc1v2-x86_64.AppImage
Reply #7
@rhubarbpieguy, it looks for libssl.so and libcrypto.so (including suffixes),
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.

Re: SSL support is not available or incomplete. 0.9.91-rc1v2-x86_64.AppImage
Reply #8
@rhubarbpieguy, it looks for libssl.so and libcrypto.so (including suffixes),

Both files are in /usr/lib.  However, although I compiled 1.0, 'version' still shows 1.1.  I tried 'make uninstall' on 1.1 but that caused other problems.

Bottom line, methinks I'll wait for the next AppImage or compilable version.

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: SSL support is not available or incomplete. 0.9.91-rc1v2-x86_64.AppImage
Reply #9
@rhubarbpieguy, yeah, I guess that extra libQt5Network.so.5 will be required...

Sadly they depend on OpenSSL and do it in crappy way, it should be implemented sanely as loadable plugin, like it's done with other stuff...
Current situation forces creation of two binaries to support both...
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.