Skip to main content

Topic: DEB file for Otter (Read 457 times)

  • pccobbler
  • [*]
DEB file for Otter
Is there any chance of having a DEB file created instead of using PPA to install Otter? I realize the Otter PPA is relatively safe, but I never use PPA. I'm using Linux Mint, but this would be relevant to any Ubuntu spin.

  • Frenzie
  • [*][*][*][*][*]
  • Administrator
Re: DEB file for Otter
Reply #1
If you click through on the PPA website a little you can also download the packages without using the PPA mechanism. E.g., here.

Btw @Emdek it says around there that the import is failing, presumably because "This branch is an import of the HEAD branch of the Git repository at https://github.com/Emdek/otter.git." (which is apparently not auto-redirected to the now proper organization URL).

  • pccobbler
  • [*]
Re: DEB file for Otter
Reply #2
@Frnze

Thanks for the reply. I should have tried that. Yes, there's a DEB file there, just what I wanted.

  • pccobbler
  • [*]
Re: DEB file for Otter
Reply #3
Oops, I spoke too soon.

Error: Dependency is not satisfiable: libhunspell-1.6-0

Linux Mint is unable to find libhunspell.

  • Frenzie
  • [*][*][*][*][*]
  • Administrator
Re: DEB file for Otter
Reply #4
@pccobbler I linked to the one for Bionic (18.04) which I figured should be most widely compatible, but there are also packages for 18.10 and 19.04 (which seems to use libhunspell-1.7-0 instead).

https://launchpad.net/~otter-browser/+archive/ubuntu/release

If your Mint is pre-18.04 it might be a little harder.

  • pccobbler
  • [*]
Re: DEB file for Otter
Reply #5
I'm running an updated version of Sylvia, built a week ago.

I tried otter-browser_1.0.01-1~disco~ppa1_amd64.deb, but it complained about libhunspell-1.7-0. Linux Mint does not know how to install libhunspell.

At least it's not as bad as Brave, the online instructions of which completely hosed update.

I purged otter-browser because I don't like having things half-installed. Thanks for your help, but I will wait until Otter is officially released.