Skip to main content

Topic: Search engine not working correctly (Read 1917 times)

  • djgl
  • [*]
Search engine not working correctly
I use Google since it usually gets the answers I need.

Using the Google search engine as setup by Otter it does not bring up the Option to search in the UK as against worldwide. In Opera there is an option "Search Tools" and when pressed I can change the country (amongst others).

Secondly if I edit the search engine for Google to Google.co.uk, when I then do a search it brings up the local directory.

Bit puzzled why it is doing that.


  • ersi
  • [*][*][*][*][*]
Re: Search engine not working correctly
Reply #1
Talking about the search bar in the browser or Google Search website? Are you logged in to Google?

  • djgl
  • [*]
Re: Search engine not working correctly
Reply #2
I am using the search bar on the top right of the screen.

First screenshot is from Opera 12 and the red arrow shows the button to press, which then brings up the second line, green arrow, and the option to change the search country.

In the second screenshot from Otter these options are missing.

Unfortunately I cannot get the screenshots down to 15K so have had to zip them


  • ersi
  • [*][*][*][*][*]
Re: Search engine not working correctly
Reply #3
So it's not a search engine problem, just Google page displays differently. Do you have more browsers to try what kind of page Google throws at you? Could be cookie settings and such. Google tends to do that. Some people are logged in to Google pages (not necessarily the search page, but +services) and for them everything looks different.

  • Frenzie
  • [*][*][*][*][*]
  • Administrator
Re: Search engine not working correctly
Reply #4
Unfortunately I cannot get the screenshots down to 15K so have had to zip them

Actually the attachments aren't really meant for pictures; space is at a premium. For screenshots I'd recommend external hosting solutions. :)

Edit: I repeated something I decided before Otter came onboard. As such it seems prudent to allow for screenshots. Limits will have to remain low, so I highly recommend cropping your screenshots as selectively as possible and processing them with pngquant. Also see here.

I should write this down somewhere in a bit more detail, but my basic screenshot tips are:
1. Crop the screenshot as much as possible without unnecessary parts of the web page or GUI. Also don't forget that you can resize your browser window if you do wish to include the GUI.
2. Usually PNG is the better choice.
3. Process your PNGs with pngquant to reduce filesize by (usually) 50-80%. Alternatively set your JPG quality as low as possible.

I think you'll be hard-pressed to find something that won't fit in a screenshot under 30kB using those guidelines.
  • Last Edit: 2014-06-26, 11:05:59 by Frenzie

  • djgl
  • [*]
Re: Search engine not working correctly
Reply #5
Thanks for your explanation and for increasing files sizes. I am aware of the file sizing but was not getting what I thought was meaningful into 15 kb.

I am now enclosing the screenshot, but also now realise that the change in search tools when you use Google for a particular country ie. google.co.uk etc. gives the option to go to the country or the world.

I have edited the "Manage Search Engines" to be google.co.uk so that now works although it is in the left column. The way Google have designed their search bar, clicking on "Search Tools" does not take up any more vertical space.

Sorry for taking up time here as I seem to have resolved the problem.

I have noticed that in Opera 12 you can add county specific search engines and it will add the correct parameters. Maybe this could be added to Otter to make life simpler?

  • Emdek
  • [*][*][*][*][*]
  • Moderator
Re: Search engine not working correctly
Reply #6
@djgl, yes, that feature is currently missing.
I'm not sure which way to add it would be best, to keep it OpenSearch compatible.
Nadszedł już czas, najwyższy czas, nienawiść zniszczyć w sobie.
The time has come, the high time, to destroy hatred in oneself.